GTA-Expert Forum: Crash di GTA quando si preme il tasto "C"...possibile conflitto fra script? - GTA-Expert Forum

Salta al contenuto

Pagina 1 di 1
  • Non puoi iniziare una nuova discussione
  • Non puoi rispondere a questa discussione

Crash di GTA quando si preme il tasto "C"...possibile conflitto fra script?

#1 L'utente è offline   Fiorellaccio 

  • Vandalo
  • Gruppo: Utenti
  • Messaggi: 74
  • Iscritto il: 24/04/20
  • GTA Preferito:GTA: San Andreas

Inviato il 04 febbraio 2021 - 00:15

Ciao a tutti...scendendo da un elicottero e premendo il tasto "C" (la cui impostazione è il comando far accovacciare CJ) il gioco mi va in crash, parte la musichetta del fastman e l'exception address è il seguente: 0x006D3B64.

Ora, ho controllato nel libro mastro degli errori e non c'è, quindi desumo che a causare tutto ciò sia lo script che mette in dotazione a tutti gli elicotteri il magnete col cavo per sollevare i mezzi.

DOMANDA:

Premesso che potrei risolvere il tutto semplicemente togliendo lo script Cleo difettoso, e considerato che non ho intenzione di farlo dato che è l'unico trovato in grado di dotare di magnete gli elicotteri, come posso risalire all'errore, e quindi ripararlo?

Lo script in questione è questo: https://www.mediafir..._Magnet.cs/file

Come sempre grazie!!

Messaggio modificato da Fiorellaccio il 04 febbraio 2021 - 00:15

0

#2 L'utente è offline   Automan 

  • Sicario
  • Gruppo: Utenti
  • Messaggi: 1877
  • Iscritto il: 10/05/14
  • Provenienza:Teramo
  • GTA Preferito:GTA: San Andreas

Inviato il 04 febbraio 2021 - 10:44

Lo script è banale, l'ho ottimizzato per W-10/Cleo4 così:

{$CLEO .cs}
thread 'HELIM' 
0000: NOP

wait 1000 
:HELIM_16
wait 0 
if 
   Player.Defined($PLAYER_CHAR)
else_jump @HELIM_16 

//-------------------------

:HELIM_43
wait 0 
if 
04A9:   actor $PLAYER_ACTOR driving_heli 
else_jump @HELIM_43 

:HELIM_63
wait 0 
if 
00E1:   player 0 pressed_key 18 
else_jump @HELIM_63 

03C0: 0@ = actor $PLAYER_ACTOR car 
wait 250
0788: enable_heli 0@ magnet 1 
Car.RemoveReferences(0@)

:HELIM_104
wait 0 
if 
   not Actor.Driving($PLAYER_ACTOR)
else_jump @HELIM_43 
jump @HELIM_104

0A93: end_custom_thread


Vedi se ti funzia, in caso contrario non si può fare altro.
A naso non penso basti attivare il magnete, altrimenti lo facevano tutti.
Manca un complicato posizionameto dello stesso, secondo me.

DOWNLOAD:
https://www.mediafir...eo4W10.rar/file
Immagine Postata
0

#3 L'utente è offline   Fiorellaccio 

  • Vandalo
  • Gruppo: Utenti
  • Messaggi: 74
  • Iscritto il: 24/04/20
  • GTA Preferito:GTA: San Andreas

Inviato il 05 febbraio 2021 - 13:20

Niente, non funonzia lo stesso...pazienza! :rolleyes:
Bella Automan!
0

Pagina 1 di 1
  • Non puoi iniziare una nuova discussione
  • Non puoi rispondere a questa discussione

1 utenti stanno leggendo questa discussione
0 utenti, 1 ospiti, 0 utenti anonimi